windows 7 / windows vista – ereignisanzeige startet nicht: fehler 4201

resultierend, aus den versuchen, meinen fehlerhaften backupdienst wieder zu aktivieren, musste ich feststellen, dass auch mein dienst zur ereignisanzeige (hier können fehlermeldungen inklusive protokollen abgerufen werden, welche profis im mircosoftforum dann auswerten können) nicht starten wollte. beim manuellen startversuch bekam ich folgende fehlermeldung:

“der dienst ‘windows-ereignisprotokoll" auf ‘lokaler computer’ konnte nicht gestartet werden. fehler 4201: der instanzname wurde nicht als gültiger name vom wmi-datenanbieter erkannt.”

es wird davon ausgegangen, dass ein fehlerhaftes windowsupdate (vista/w7) dafür verantwortlich ist. alternativ können jedoch auch bestimmte externe tuningtools dafür verantwortlich sein. auf grund des fehlers entstehen jedoch unstimmtigkeiten in der rechte- und besitzverwaltung in windows, woraufhin der dienst nicht mehr als windowseigener dienst erkannt und deaktiviert wird. demnach lässt er sich auch nicht mehr reaktivieren. da die rechte-/besitzverhältnisse nur von dem einen ordner “rtbackup” entscheidend sind, lässt sich dieser fehler relativ einfach beheben und die ereignisanzeige zügig wieder in betrieb nehmen. das einfachste dazu ist, diesen ordner zu löschen und einen neustart des systems auszuführen. beim hochfahren wird der ordner automatisch von windows neu erstellt und zwar unter den alten funktionierenden rechte-/besitzeigenschaften. die ereignisanzeige sollte nun wieder einwandfrei funktionieren.

um den angesprochenen ordner jedoch zu löschen, muss man vorab noch eine kleine hürde meistern. da sich der ordner standardmäßig unter “c:\windows\system32\logfiles\wmi” befinden sollte, ist er auch von windows dauerhaft in beschlag genommen. will man ihn per normalem windowsbefehl löschen, wird moniert, dass die datei/der ordner grade von einem anderen programm genutzt wird. da sich dies nicht ermitteln lässt, hilft nur ein brutaler kill dieser anwendungen. dazu kann man sich unter anderem auf den chip.de-servern das tool “unlocker” herunterladen. es ist in der 32bit- sowie in der 64bit-version verfügbar. diese datei muss installiert werden. anschließend sollte man im kontextmenü per rechtsklick auf den ordner einen eintrag namens “unlocker” finden. mittels des befehls “löschen” werden alle darauf zugreifenden programme einfach abgewürgt, so dass der ordner “rtbackup” vom tool gelöscht werden kann.

bei mir funktionierte diese vorgehensweise einwandfrei. ich übernehme natürlich trotzdem keine verantwortung für fehlschläge und/oder datenverluste jeglicher art.

Werbeanzeigen